Workaround for TVAnts/StreamTorrent + Vista + WMP11
Results 1 to 7 of 7

Thread: Workaround for TVAnts/StreamTorrent + Vista + WMP11

  1. #1
    Join Date
    Jun 2015
    Location
    Gator Country
    Posts
    13,494
    Thanks
    19,149
    Thanked 27,011 Times in 10,727 Posts

    Workaround for TVAnts/StreamTorrent + Vista + WMP11

    Read the entire thread. Final solutions are included below. ~ft420


    TVAnts 1.0.0.59 Build 0835
    Vista Home Premium with SP1
    Windows Media Player 11

    [confirmed working 12 April 2009]

    If you do a normal TVants installation (and enter a working proxy if needed) I found that the stream buffers nicely but the media player never starts.

    I couldn't find anyone on internet who had got it working, and finally solved it myself. There was lots of advice that didn't help me: I DIDN'T need to run any TCP patches for vista because mine was buffering well. If yours isn't buffering you need to fix this before following my post here. I DIDN'T need to uninstall any download managers.

    If you live in a country where access to TVAnts is blocked you will also have to use a proxy (this is well covered in other threads).

    I turned off User Account Control, but I don't know if this is necessary. I could find out but I'm watching Man U giving Inter Milan a beating. (EDIT: I've since tested this: you don't need to turn off User Account Control)

    1. Download latest TVAnts
    2. Right-click on it and choose "Run as administrator"
    3. After it is installed, find the installed program, in c:/program files/ tvants
    4. Right-click on Tvants.exe, choose properties / compatability, select "Run as administrator" (might not be necessary) and "run this program in compatability mode for: Windows XP SP2".
    5. That's it.

    When you click on a TVAnts channel it will buffer well, but it will not automatically open the media player. After about 2 minutes you will get a screen saying that it can't open the stream in the internal player. Click YES to open the Windows Default Media player. WMP will open and after a little more buffering the TV programme will start.

    If you've got a solution that automatically opens the media player, please post details!


    ...originally posted by Martist. Thanks!

  2. #2
    Join Date
    Jun 2015
    Location
    Gator Country
    Posts
    13,494
    Thanks
    19,149
    Thanked 27,011 Times in 10,727 Posts

    issues

    when TVants asks if i want to open an external player i get an error in WMP saying cannot play the file.


    ....originally posted by avinitski. Thanks!

  3. #3
    Join Date
    Jun 2015
    Location
    Gator Country
    Posts
    13,494
    Thanks
    19,149
    Thanked 27,011 Times in 10,727 Posts

    fix found

    Some news from the TVU staff.

    From their forum:

    Hello all -

    Problem description: you start a TVU channel, and in the video window you see a message that says "Navigation to the web page was cancelled". The channel does not start.

    We believe that we’ve identified the source of the problem, which is a bad setting in the Windows “hosts” file. We’re confident that it’s not our software that made this change. It seems to be a pretty widespread problem. Please try the following to fix it:

    Close the TVUPlayer (or the web page on which you are watching TVU)
    Open the file c:\Windows\System32\drivers\etc\hosts
    (assuming c: is the drive your OS is on; use an application like Notepad to edit the file)

    On a default system, there should be a line that says (there is a tab between the “127.0.0.1” and the “localhost”):
    127.0.0.1 localhost

    On systems that are broken (i.e. the TVUPlayer says “Navigation cancelled” when you start up a channel), we’ve found that this line has been deleted, and replaced with one that says:
    ::1
    (or maybe ::1 localhost)

    To fix this problem, add the line “127”.0.0.1 localhost” line back in above the “::1” line, like this:

    127.0.0.1 localhost
    ::1 localhost

    Then save the file.
    Restart the TVUPlayer; the problem should be gone.

    Regards,
    The TVU Team





    This will make every player work. LOSTNORMAN posted this on the TVU forum on this site. I just copy pasted it here so that everyone can fix their problem. ENJOY



    originally posted by amk87. Thanks!

  4. #4
    Join Date
    Jun 2015
    Location
    Gator Country
    Posts
    13,494
    Thanks
    19,149
    Thanked 27,011 Times in 10,727 Posts
    superb. simply great. this solved all my problems with tvu ,tvants and spvod. thank you very much.



    originally posted by muckman. Thanks!

  5. #5
    Join Date
    Jun 2015
    Location
    Gator Country
    Posts
    13,494
    Thanks
    19,149
    Thanked 27,011 Times in 10,727 Posts
    Originally Posted by boris40scot
    i done what u said but it wont let me save it it says cannot create the c:\Windows\System32\drivers\etc\hosts make sure path and file name are correct.
    It is because it is not letting you access the file as an administrator. If you are using vista right click on the file and click on the security tab, from there give you user full control of the file and it will let you save the changes.


    originally posted by amk87. Thanks!

  6. #6
    Join Date
    Jun 2015
    Location
    Gator Country
    Posts
    13,494
    Thanks
    19,149
    Thanked 27,011 Times in 10,727 Posts
    Originally Posted by boris40scot
    i done what u said but it wont let me save it it says cannot create the c:\Windows\System32\drivers\etc\hosts make sure path and file name are correct.
    Even though you own Vista, Vista thinks that it owns you. You have to remind it who's boss. I did it like this:

    Right-click on hosts, choose properties / security

    c:\Windows\System32\drivers\etc\hosts

    which means: on the c drive, open the Windows folder, then inside that the System32 folder, then.....


    Click EDIT.
    Select Users.
    In Permissions for Users: note which permissions are allowed. You're going to set it back to this later. Click the box for Allow Full control. A tick should appear in it. Press OK and now you can edit the host file.

    Important: trojans and other bad things sometimes try to mess with your host file, so after you have finished editing go back to the permissions page and set the permissions back to what they were before (mine were: allow only Read & Execute and Read)



    ....originally posted by Martist. Thanks!

  7. #7
    Join Date
    Jun 2015
    Location
    Gator Country
    Posts
    13,494
    Thanks
    19,149
    Thanked 27,011 Times in 10,727 Posts
    Guys you are great!
    THX a lot for this useful thread!
    i had the same problems with tvants and tvu but with your description to change the host file and the permission, i got everything back to run as usual...





    originally posted by TscHeChan. Thanks!

  8. #8
    Join Date
    Jul 2015
    Posts
    522
    Thanks
    2,624
    Thanked 1,948 Times in 522 Posts
    ..

  9. The Following User Says Thank You to All Blacks For This Useful Post:

    ft420 (22-12-2018)

  10. #9
    Join Date
    Jun 2015
    Location
    Gator Country
    Posts
    13,494
    Thanks
    19,149
    Thanked 27,011 Times in 10,727 Posts
    @DerrickNor

    you are now registered. You may post, etc. welcome!!

    If you ain't a Gator, you must be................ Gator Bait !!
    Big CHEERS To All Streamers! Geaux Saints!


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •